Archive for March, 2010

That’s why you should be banned from using Twitter

Posted in funny, twitter on March 29th, 2010 by fseek – 2 Comments

If you use Twitter, you probably have a list of things that you hate about it. However, what annoys me the most is not the platform itself (as bad as it it), but the way some people use it.

If you do any of those things you should be forever BANNED from using Twitter:

  • You use “Tweeple” to refer to people on Twitter. Something like “hi Tweeple” is banned. In fact, if you modify any word to be Twitter specific, you should shoot yourself. The only exception is “tweet” for the single messages itself.
  • Your break down your message into 2 or more tweets. Twitter has a 140 chars limitation and if you can’t summarize your thoughts with this limitation, do not break it down on multiple tweets. Write about it on a blog and link to it.
  • You say “good morning” before your post your first tweet and “good night” before going to sleep. Seriously? Do I even have to explain why you shouldn’t do it?
  • You “Follow Friday” a lot of people without any explanation. I hate, really hate when I see 10 tweets from someone on a Friday full of @names and a #FF at the end. Why should I follow them? Choose one or two and be specific why they are good.
  • Your description has the words “SEO” , “Expert”, “Social Media” and “Marketing”.
  • You beg for people to RT your posts. If they liked it, they will RT your content. Don’t even bother asking for it.

 
 
 
Did I miss anything on this list? What else should be banned? Let me know and I will update this post.

 
I broke all the rules today. Check it out:

backtweets is awesome!

Posted in tips, twitter on March 24th, 2010 by fseek – Be the first to comment

I don’t know how I missed it for so long, but http://backtweets.com is really awesome.

backtweet

Why is it awesome? One of the biggest drawbacks of having short urls on twitter is that you can’t search for tweets referencing your domain. And just this week I was trying to see who mentioned this site on twitter, when I found their service. Very simple concept and very well done (note that this is not a paid post, I just really liked it).

This is the output when I searched for fseek.me:
backtweet

One problem that I noticed is that some links were missing, but very few of them. I guess they monitor the twitter stream (for everyone), so missing a few tweets is expected.

That’s why I will not invest any money in you

Posted in startups on March 18th, 2010 by fseek – 6 Comments

I have been in the startup game for a while. My last jobs were with startups and I just joined a 3-person startup a few months ago. Yes, it is a lot of work, but hopefully it will pay off in the future.

I also love to read about startups and about what other companies are doing. That’s why I have been following Hacker News for a while. However, I am starting to notice a trend that is annoying me a lot:

  • People are doing some small weekend projects and calling it a “startup”
  • Every feedback request for a web application is now “review my startup”

Don’t get me wrong, there are lots of cool projects and applications that I get to try daily, thanks to the “ASK HN” threads, but people need to know the difference between a cool weekend project and a real company.

Do you know what it is?

Real startups (companies) are in business to make money!

Shocking, no? Everything else is just a cool fun project that we may use now and then. If you started an interesting web application that your friends tried and liked, that’s still not a startup. That’s only a web application, nothing else. Can you make money of it? Maybe… Maybe not. Most probably not.

“So why wouldn’t you invest any money in me?”, you might ask? What has the title to do with this post?

The problem is that people are taking these cool weekend projects and trying to make money of them. They are trying to build companies out of what was just a fun web application. What’s worse? They don’t even know how they can make money. I think that 99.9% of the time when I ask these companies how they are going to make money, all they can come with is the “ads” or “Freemium” answer. Here is the truth:

  • A company to make money based on advertising has to be able to reach a very large audience. Do you think that your application that your geek friends like is going to be like that? If not, forget the “ads” model.
  • Same thing for the Freemium model. Do you have something that your free users really want? Actually, do you have enough users for that to work? On the best bet 1% of your users will “upgrade” to a paid account if it is very cheap. Do you have a couple hundred thousand users? Even if you have 100,000 users and 1,000 pay for your paid account. If you charge $10 per month, you are still making only 10k per month, barely making the salary of one person. No one will invest in a company like that

So, that’s why I would never invest money in “your” company. Unless you have a solid revenue model, a very expensive product that people will buy or you can reach a very large audience, it will not go anywhere.

The worst model at all? An ad-based web application seeling “Premium” accounts that the main advantage is being ad-free.

Brazilians, be proud of your President

Posted in brazil, funny, politics on March 17th, 2010 by fseek – Be the first to comment

I love Brazil! It is a beautiful country full of natural beauties. However, there is one thing that Brazilians can be really proud of: their President.

He dresses well:
Lula

Has a cute belly button:
Lula cute (belly)

Cares about the environment:

Lula peeing

Cares about its people:
Lula touching itself

And even plays soccer!

Lula playing soccer

How cool is that?

The guy who invented daylight saving time (DST) should be shot

Posted in funny on March 16th, 2010 by fseek – Be the first to comment

Yes, you read it right. He should be shot. One hour earlier every morning? Kids sleeping later because it is still sunny?

Oh, he is dead already. Justice was made.

Search and replace inside a MySQL database

Posted in mysql, tips on March 13th, 2010 by fseek – 3 Comments

Have you ever wanted to modify multiple rows and tables inside your MySQL database? We have a simple way to do it.

Well, yesterday I had to modify in one of our databases (a big one), every occurrence of an email address (contact@company.com) to another one (sales@company.com). Doing that via our web interface would take a long time, so I did the simple way:

1- Backup your MySQL database using Mysqldump

$ mysqldump -u dbuser -pdbpass dbname > dump.sql

Now we have our database backed up at dump.sql

2- Search and replace inside your MySQL dump

We did this very easily with sed to replace “contact” for “sales”. Just change for whatever values you want to replace.

$ cat dump.sql | sed ’s/contact@company/sales@company/gi’ > dump-fixed.sql

Note that we did a case insensitve search for contact@company.com and replace that with the sales address. Also, we used the “g” modifier to apply to all cases (not the first one in the line).

3- Restore your database using the modified dump

$ mysql -u dbuser -pdbpass dbname < dump-fixed.sql

Yes, it was that simple. No more running a bunch of INSERTS, DELETES, ALTER tables, etc…

Real reasons why most companies don’t waste their time developing software for Linux

Posted in linux, rant on March 12th, 2010 by fseek – 13 Comments

I am a Linux fan and I use that all the time, but there are some things that really, (REALLY) have to be changed before most companies will even start to take it serious. Do you want to see that cool application ported to Linux? Or that software your uncle just bought at Best Buy? Here’s why it is not supported on Linux:

 
1-There is no binary compatibility between distributions (or even between versions of the same distribution)

That’s so annoying and probably THE reason why most companies don’t write software for Linux. If I get an executable that I compiled on my Windows XP, it will run on Windows 2000, Vista, 2003 and maybe on Windows 98. People complain about Microsoft and all the stuff they do wrong, but they are good at backwards compatibility. Linux should do the same!

Why, God, why the binary I just compiled on Ubuntu 7.10 won’t work on my 9.04? Why won’t it work on Red Hat?

I know there are technical issues, like dynamic libraries, GCC version, etc, but that is a solvable problem. It shouldn’t have to be that way anymore. My own company won’t even bother wasting time migrating our code to Linux because of that. Within the same distribution, the code should be backwards compatible, and the Red Hat, Ubuntu, SuSe guys need to talk to each other to get in sync! We, as the community have to demand that they do so. Let the competition to the side a bit and get that sorted out. It is just going to be better for everyone in the long run.
*crap, even a binary I compile on Solaris 9, works well on Solaris 7 and 8…

 
2-Installation nightmare!

I know, I know.. apt-get is awesome, yum is pretty good! synaptic allows you to install “anything” you want. Users don’t have to worry about dependency…

However, there is no universal way to install an application. Companies used to build Windows software have one installer and that’s it. Can you imagine having to do one RPM, one DEB, one .tar.gz, etc? Each one with different binaries because the SuSe RPM doesn’t work at Red Hat? I am not talking about the complications that the end-user faces with that, but the issue that software developers have with it.

If the Linux community want companies to start developing and migrating their software to Linux, we need an universal installer. Yes, Fedora can still use yum, same for Debian and apt-get. But they all need to support a single installation method. Which one? I don’t care, but they have to talk to each other and decide.

 
3- Not enough user base and complacent users

Linux users should stop using Wine. Should stop dual booting to Windows to use a software that is not supported on Linux. We have to complain to the companies and let them know that they are losing a client and money because of that.

 
4- VI is still installed by default everywhere!

That’s a crime! Who will waste time with Linux if it still comes with “vi” by default? Emacs is so much better that it is not even funny.

Ok, I am joking… I love vi :)

Only time when you should use a Pie Chart

Posted in funny on March 11th, 2010 by fseek – 4 Comments

Pie Charts and Powerpoint presentations are the two things that I hate the most (more on that another day). They are 99% of the time useless, with no-content and merely used to fill blank space and look pretty. Well, just like this post.

However, Pie Charts can be very useful to graph one thing and one thing only:
Pie Chart

Worst PHP advice ever

Posted in apache, bad-advice, php on March 10th, 2010 by fseek – Be the first to comment

Last night I was browsing some books at the bookstore and glanced over at the following advice on a PHP+Flash book:

“To improve performance disable Apache access and error logging.

 
A bit after, another performance suggestion:

“To improve performance, minimize the ammount of error handling routines“.

Seriously? Are they kidding me? What’s next? Do not sanitize user input to improve performance?Unfortunately I can’t remember the book name, since I threw it far away and ran back home.

*have you read this book? Remember the name? If I can’t figure it out soon, I will go to the bookstore today again just to put them on shame ;)

OSSEC rule to ignore the msn/bing bot

Posted in ossec, security on March 8th, 2010 by fseek – Be the first to comment

You know, the MSN (Bing/Live) crawler is a strange bot. It keeps trying to access inexistent files on my server, generating a bunch of 404’s.

OSSEC, being smart as it is, goes ahead and blocks them with its “Web-based file scanning’ alert. OSSEC is doing its part, but I don’t want to block MSN/BING (even though it likes to crawl invalid pages).

The solution? This simple rule:

<rule id="100308" level="0">
  <if_sid>31101</if_sid>
  <id>404</id>
  <description>Ignoring msn bot.</description>
  <srcip>65.55.0.0/16</srcip>
  <match> "msnbot</match>
</rule>

<rule id="100310" level="0">
  <if_sid>31101</if_sid>
  <id>404</id>
  <description>Ignoring msn bot.</description>
  <srcip>207.46.0.0/16</srcip>
  <match> "msnbot</match>
</rule>

No more alerts for it…